import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^([0-9]{9})\\s+(E[0-9]+(?: [0-9]+)?)\\s*-\\s*([^-\\n]+(?:-[^-\\n]+)*?)(?>-([0-9]+\\.[0-9]{1,2}))?$";
final String string = "700012839 E703 - DOMAINE PREST NON OUVERT PAR L AMC\n"
+ "000001708 E0480 0051- NUAT. (DRE) 0.00-0.00\n"
+ "000279001 E0317 0511 - INCOMPATIBILITE ASU-NAT / REGIME 0.00-1.00";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}