re = /(?m)^([0-9]{9})\s+(E[0-9]+(?: [0-9]+)?)\s*-\s*([^-\n]+(?:-[^-\n]+)*?)(?>-([0-9]+\.[0-9]{1,2}))?$/
str = '700012839 E703 - DOMAINE PREST NON OUVERT PAR L AMC
000001708 E0480 0051- NUAT. (DRE) 0.00-0.00
000279001 E0317 0511 - INCOMPATIBILITE ASU-NAT / REGIME 0.00-1.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end