using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[^""]*(?:""[^""]*)*""";
string input = @"""USE CODE ""Gef, sdf"" FROM 1/7/07"", Delete , Hello , How are you ? , ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}