$re = '/"[^"]*(?:""[^"]*)*"/';
$str = '"USE CODE ""Gef, sdf"" FROM 1/7/07", Delete , Hello , How are you ? , ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);