$re = '/^(?:00|\+)[0-9]{4}-?[0-9]{7}$/m';
$str = '006018-2031218
0060182031218
+6018-2031218
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);