import re
regex = re.compile(r"^(?:00|\+)[0-9]{4}-?[0-9]{7}$", flags=re.MULTILINE)
test_str = ("006018-2031218\n"
"0060182031218\n"
"+6018-2031218\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")