package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\d|\.]+)`)
var str = `PSU 12.1.0.2.170117`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}