import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<!--.+-->|<[^>]+>";
final String string = "<html>\n"
+ "<head>\n"
+ " <title>Hello World</title>\n"
+ " <!-- Skip this section if error count > 0 -->\n"
+ "</head>\n"
+ "<body>\n"
+ " The whole world is facing economic challenge due to Coronavirus pandemic.\n"
+ "</body>\n"
+ "</html>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}