re = /<!--.+-->|<[^>]+>/m
str = '<html>
<head>
<title>Hello World</title>
<!-- Skip this section if error count > 0 -->
</head>
<body>
The whole world is facing economic challenge due to Coronavirus pandemic.
</body>
</html>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end