const regex = /(?<![a-zA-Z/])(?:https?:)?\/{1,2}[a-zA-Z]\S*(?:\b|(?<!\))\)\)(?!\S))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![a-zA-Z\/])(?:https?:)?\\\/{1,2}[a-zA-Z]\\S*(?:\\b|(?<!\\))\\)\\)(?!\\S))', 'gm')
const str = `https://docs.google.com/picker?protocol=gadgets&nav=(("fonts")
https://docs.google.com/picker?protocol=gadgets&nav=(("fonts"))
: https://docs.google.com/picker?protocol=gadgets&nav=(("fonts")))
https://docs.google.com/picker?protocol=gadgets&nav=(("fonts")
-> should match https:\\\\docs.google.com/picker?protocol=gadgets&nav=(("fonts
https://docs.google.com/picker?protocol=gadgets&nav=(("fonts"))
-> should match all the URL (the original URL)
https://docs.google.com/picker?protocol=gadgets&nav=(("fonts")))
-> should match https:\\\\docs.google.com/picker?protocol=gadgets&nav=(("fonts`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}