import Foundation
let pattern = #"(?<![a-zA-Z/])(?:https?:)?\/{1,2}[a-zA-Z]\S*(?:\b|(?<!\))\)\)(?!\S))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://docs.google.com/picker?protocol=gadgets&nav=(("fonts")
https://docs.google.com/picker?protocol=gadgets&nav=(("fonts"))
: https://docs.google.com/picker?protocol=gadgets&nav=(("fonts")))
https://docs.google.com/picker?protocol=gadgets&nav=(("fonts")
-> should match https:\\docs.google.com/picker?protocol=gadgets&nav=(("fonts
https://docs.google.com/picker?protocol=gadgets&nav=(("fonts"))
-> should match all the URL (the original URL)
https://docs.google.com/picker?protocol=gadgets&nav=(("fonts")))
-> should match https:\\docs.google.com/picker?protocol=gadgets&nav=(("fonts
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)