#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([A-z \-]*)(?:,(( [A-z\-\.]*){0,3}(?:\(I*\))?))(.*)\s(\(.*\))\s*(\[.*\])?"
Local $sString = "Alba, Tota A la legi≤n le gustan las mujeres... y a las mujeres, les gusta la legi≤n (1976) [Do±a Euduviges] <20>" & @CRLF & _
"Alba, Vivi Parφs Tombuct· (1999) [Azafata]" & @CRLF & _
"Alba, Yashana Nightmare at Sleepaway Camp on Friday the 13th Part XII (2012) [Tammy Faye] <7>" & @CRLF & _
"Albacar, Mar "└nima" (2009) {(#6.3)} [Herself]" & @CRLF & _
"Albacete, Isabel Cßndida (2006) [Locutora Anuncio] <33>" & @CRLF & _
"Albach, Maeghan Evangerion shin gekij⌠ban: Jo (2007) (voice: English version) [Additional Voices]" & @CRLF & _
"Albach, Meaghan "Suzuka" (2005) {Egao (#1.2)} [Additional Voices]" & @CRLF & _
"Albach, Stephanie Handcart (2002) [Abigail] <2>" & @CRLF & _
"Albach-Retty, Rosa Abenteuer in Wien (1952)" & @CRLF & _
"Albachten, Kim As Virgins Fall (2003) [Madge Palsey]" & @CRLF & _
"Albadalejo, Ana L'Agent (2013) (V) [The Party] <6>" & @CRLF & _
"Albaicφn, Angustias Violetas imperiales (1952) (uncredited)" & @CRLF & _
"Albaicφn, Marφa El secreto del capitßn O'Hara (1968)" & @CRLF & _
"Albain, Julia A Very Potter Musical (2009) (TV) [Crabbe] <14>" & @CRLF & _
"Albajari, Nora La traque (2008) (TV) <40>" & @CRLF & _
"Albakry, Mouna Born of War (2014) [Wife] <17>" & @CRLF & _
"Albala, Shari Syx (2007) [Tour Group Member]" & @CRLF & _
"Albaladejo, Ana Cachorro (2004) [Profesora joven] <29>" & @CRLF & _
"Albaladejo, Geli 20 centφmetros (2005) [Funcionaria morena - Empleada ETT] <24>" & @CRLF & _
"Albaladejo, Lola Manolito Gafotas (1999) [Madre 1] <27>" & @CRLF & _
"Albaladejo, Maria "└nima" (2009) {(#7.17)} [Herself]" & @CRLF & _
"Albaladejo, Marina "Menudo show" (1995) {(1997-07-26)} [Paloma San Basilio]" & @CRLF & _
"Albaladejo, Rocφo "La voz" (2012) {(#1.1)} [Herself - Contestant]" & @CRLF & _
"Albaladejo, Tonia "Teatro estudio" (1976) {Las aleluyas del se±or Esteve}" & @CRLF & _
"Albalat, Laura Insaciable (2013) [Victima casa somni]" & @CRLF & _
"Albalate, Gloria Cinco minutos para medianoche (2010)" & @CRLF & _
"Albalate, N·ria Coco rallado (2008) [Mujer]" & @CRLF & _
"Albamonte, Cora Empalagßme que me gusta (2006) [Teodora]" & @CRLF & _
"Albamonti, Jennifer "The Adventures of Indiana James" (2015) [Bama Breeze Crew Member]" & @CRLF & _
"Alban, Alissa Carried Away (1996) [School Board Superintendent] <10>" & @CRLF & _
"Alban, Carolyn The Spectre of Edgar Allan Poe (1974) [Virginia Clemm] <17>" & @CRLF & _
"Alban, Chantal "Janique aimΘe" (1963) [IrΦne]" & @CRLF & _
"Alban, Elizabeth Wildflowers (1999) [Poker Player] <37>" & @CRLF & _
"Alban, Franτoise De quoi tu te mΩles Daniela! (1961) <6>" & @CRLF & _
"Alban, Ilse "The Man Called X" (1956) {Voice on Tape} <7>" & @CRLF & _
"Alban, Jamie The Halfway House (2004) (as Jaimie Alban) [Halfway House Girl] <25>" & @CRLF & _
"Alban, Jani Journal d'un coopΘrant (2010) [Mathilde]" & @CRLF & _
"Alban, Karine Dangerous Dreams - Die Macht des Geldes (2001) (V)" & @CRLF & _
"Alban, Luz Je suis barbara morgan (2015) [Danseuse]" & @CRLF & _
"Alban, Michele A±o u±a (2007) [Grandma Michele] <4>" & @CRLF & _
"Alban, Patricia Satanico Pandemonium: La Sexorcista (1975) <14>" & @CRLF & _
"Alban, Sarah Eden 11:11 (2010) [Young Girl, Cat]" & @CRLF & _
"Alban-Zapata, Joy Das geteilte Glⁿck (2010) (TV) [Mimi Wagner] <7>" & @CRLF & _
"Albana, Maya Danish Music Awards 2004 (2004) (TV) [Herself - Presenter (┼rets udenlandske hit)]" & @CRLF & _
"Albanchaabouchi, Kahina Bloody Mary (2011/I) [Air hostess]" & @CRLF & _
"Albane Rigadin et la poudre d'amour (1912)" & @CRLF & _
"Albane, Blanche L'homme au grand manteau (1911) <3>" & @CRLF & _
"Albanel, Christine L'aventure du Rond-Point: Audace joyeuse et rire de rΘsistance (2010) (TV) [Herself]" & @CRLF & _
"Albanense, Nadia "Como pan caliente" (1996) [Pelusa] <24>" & @CRLF & _
"Albanes, Carolina Agent: Undercover (2008) {{SUSPENDED}} [Luna]" & @CRLF & _
"Albanese, Anna "Starcade" (1982) {(#1.17)} [Herself - Contestant] <4>" & @CRLF & _
"Albanese, Ashleigh Crown Oaks Day (2011) (TV) [Herself]" & @CRLF & _
"Albanese, Chrissy Fat Kid Luv (2009) [Partygoer] <13>" & @CRLF & _
"Albanese, Francesca (R)evolution (2014) (V) [The Girl]" & @CRLF & _
"Albanese, Giada Banzai (1997) [Duty Free Cashier]" & @CRLF & _
"Albanese, Judy "Cavuto on Business" (2000) {(2014-07-18)} [Herself (segment "Let Me Be Brief")]" & @CRLF & _
"Albanese, Kelly Buffy the Vampire Slayer: Season 8 Motion Comic (2011) (V) [Buffy]" & @CRLF & _
"Albanese, Lauren "Confessions of a Bartender" (2015) [(2014)]" & @CRLF & _
"Albanese, Licia Little Shop of Erotica (2001) [Restaurant Patron] <21>" & @CRLF & _
"Albanese, Lindsay Operation Shock and Awe... some (2008) [Jenni]" & @CRLF & _
"Albanese, Marta Operaci≤n masacre (1973)" & @CRLF & _
"Albanese, Michela Il burbero (1986)" & @CRLF & _
"Albanese, Michele "StartUpers" (2012) [Herself] <3>" & @CRLF & _
"Albanese, Stephanie Eternal Black (2014) [Adult Sam/Narrator]" & @CRLF & _
"Albanese, Tina "JAG" (1995) {Code Blue (#2.13)} (uncredited) [Cashier]" & @CRLF & _
"Albanese, Zira Alzira's Story (2000) [Herself] <6>" & @CRLF & _
"Albanese-Smith, Amanda "The Stools" (2015) {Chapter Five: More 1957 (#1.5)} [Betheny Bedstuy-Jones]" & @CRLF & _
"Albanesi, Meggie Darby and Joan (1919) [Elin Garry] <5>" & @CRLF & _
"Albanez, Caroline Manny's Obituary (2011) [Maggie] <5>" & @CRLF & _
"Albanez, Diana "Teachers Talking About..." (2014) [Herself - Guest]" & @CRLF & _
"Albaneze, Ljiljana "Svaki dan dobar dan" (2013) {Ucenje - (Ni) je mucenje (#1.3)} [Herself]" & @CRLF & _
"Albanezzi, Nilza O Artesπo de Mulheres (1978) <10>" & @CRLF & _
"Albani, Andrea (I) Agφtese antes de usarla (1983) (as Laly Espinet) [Elisa] <11>" & @CRLF & _
"Albani, Angela Patima (1975) <20>" & @CRLF & _
"Albani, Elsa Come, quando, perchΘ (1969) [Marco's mother] <4>" & @CRLF & _
"Albani, Laura Auto-Ceva - Eine Begegnung und fⁿnf Reisen nach Bukarest (2010) [Herself] <2>" & @CRLF & _
"Albani, Marcella Amore in fuga (1921)" & @CRLF & _
"Albani, Maria Teresa Amore e ginnastica (1973) <11>" & @CRLF & _
"Albani, Olga The Lady in Black (1935) (as Countess Olga Albani) [Countess Olga Albani] <1>" & @CRLF & _
"Albani, Zoe Din prea multa dragoste (1986)" & @CRLF & _
"Albani-Cook, Maria "Snapped: Killer Couples" (2011) {Jennifer Henderson & Skylar Deleon (#1.2)} [Notary]" & @CRLF & _
"Albania, Annie In da Red Corner (2006) [Real Boxer] <66>" & @CRLF & _
"Albaniah, Nor Al-Hijab (2011) [Datin] <4>" & @CRLF & _
"Albano, Bea Edward Scissorhands (1990) [Rich Widow/TV] <36>" & @CRLF & _
"Albano, Donna A Modern Day Western: The Sanchez Saga (1997) [Detective Leslie Henderson]" & @CRLF & _
"Albano, Editha Thelma (2011) [Empanada Vendor, Batac Market] <28>" & @CRLF & _
"Albano, Flora R. My Name Is Bruce (2007) [Old Lady] <36>" & @CRLF & _
"Albano, Gia Santa Claws (2014) [Little Girl] <22>" & @CRLF & _
"Albano, Jennie (I) The Crib (2005) [Alluring Nurse #2]" & @CRLF & _
"Albano, Jennie (II) "Take the Money & Run" (2011) {The South Beach Sisters (#1.3)} [Herself - Contestant] <6>" & @CRLF & _
"Albano, Jennifer 200 Cigarettes (1999) [Cheryl] <3>" & @CRLF & _
"Albano, Jessica "Prince$$" (2010) {Laura H. (#2.27)} [Herself - Stylist]" & @CRLF & _
"Albano, Jill The Grounded (2013/I) [Missy-Ann] <1>" & @CRLF & _
"Albano, Kelly 30 Seconds from Oblivion (2010) (V) (as Kelly Marchand) [Lexi Warthers]" & @CRLF & _
"Albano, Mariela Placer sangriento (1967)" & @CRLF & _
"Albano, Martina La solitudine dei numeri primi (2010) [Young Alice] <3>" & @CRLF & _
"Albano, Mary La bestia desnuda (1971)" & @CRLF & _
"Albano, Meghan Pay It Forward (2000) (uncredited) [Neighbor]" & @CRLF & _
"Albano, Michele "Throwdown with Bobby Flay" (2006) {Pumpkin Pie (#7.5)} [Herself - Owner, Michele's Pies]" & @CRLF & _
"Albano, Patrizia Attenti a quei due napoletani (1980)" & @CRLF & _
"Albano, Pina Faida (1988)" & @CRLF & _
"Albano, Rebecca "Take the Money & Run" (2011) {The South Beach Sisters (#1.3)} (as Rebecca) [Herself - Contestant] <5>" & @CRLF & _
"Albano, Serena Ultime notizie (1995)" & @CRLF & _
"Albano, Stefania Il cappellino (2009)" & @CRLF & _
"Albano, Tulsi 10 Hours State of Emergency (2013) [News Reporter]" & @CRLF & _
"Albano, Victoria Jack Rio (2008) [Waitress]" & @CRLF & _
"Albanova, Olga Nelegal (2006) [Svetlana] <3>" & @CRLF & _
"Albany, Alison Busted (2015) [Office Worker] <19>" & @CRLF & _
"Albany, Fernande Flagrant dΘlit (1931) [Hortense] <7>" & @CRLF & _
"Albany, Jade (I) "Camp" (2013) {Pilot (#1.1)} [Alex] <18>" & @CRLF & _
"Albao, Baby Scaregivers (2008) [Jewelry Shop Customer] <57>" & @CRLF & _
"Albao, Theresita Scaregivers (2008) [Jewelry Shop Customer] <58>" & @CRLF & _
"Albar, Shelley The Bridge (2006/I) [Herself - David's Friend, Oakland, CA] <25>" & @CRLF & _
"Albarado, Clara La voz del agua (2015) [Mezzosoprano]" & @CRLF & _
"Albardonedo, Deborah Bellas durmientes (2001) [Mujer de cuatro piernas] <29>" & @CRLF & _
"Albareda, Teresa Pell Fina (2015)" & @CRLF & _
"Albareil, Josette PygomΦle (2011) [La Servante] <5>" & @CRLF & _
"Albarella, Jackie Traveling Salesmen (2008) [Mystic Judy Giordano] <6>" & @CRLF & _
"Albarella, Karen Fixations (2010) [Group Member]" & @CRLF & _
"Albarelli, Kathryn "Law & Order: Criminal Intent" (2001) {Unchained (#5.4)} [Judy Cordova] <26>" & @CRLF & _
"Albares, Ana Isabel (I) XIV Premios Anuales Iris de la Academia de TV (2012) (TV) [Herself]" & @CRLF & _
"Albares, Ana Isabel (II) XIV Premios Anuales Iris de la Academia de TV (2012) (TV) [Herself - Presenter]" & @CRLF & _
"Albaret, Sylvia Les chants de Mandrin (2011) [Mandrinette] <10>" & @CRLF & _
"Albarez, Angela Franchise (2012)" & @CRLF & _
"Albarez, Maria Dolores Ellos Volvieron (2015) [Classmate] <21>" & @CRLF & _
"Albaroto, Carla Thelma (2011) [University of Makati] <491>" & @CRLF & _
"Albarracin, Mayra Insane (????) [Belen]" & @CRLF & _
"Albarracin, Taca Nocturnal Jake (2009) [Sophia] <2>" & @CRLF & _
"Albarracφn, Adriana "La casa de las dos palmas" (1991) [Hortencia Herreros (1991)]" & @CRLF & _
"Albarracφn, Magnolia La pasi≤n de Gabriel (2008) [Do±a Carmen]" & @CRLF & _
"Albarracφn, Marcela Invierno ausente (2005) [Elvira]" & @CRLF & _
"Albarracφn, Nadia "Guapas" (2014) {Falsa alarma (#1.168)} [Bombero]" & @CRLF & _
"Albarreal, Cecilia Dramagogφa barata (2005)" & @CRLF & _
"Albarret, CΘleste Portrait-souvenir: Marcel Proust (1962) (TV) [Herself]" & @CRLF & _
"Albarrosa, Rosanny Stand Clear of the Closing Doors (2013) [Nail clipper]" & @CRLF & _
"Albarrßn, Karla "Amor gitano" (1999) <32>" & @CRLF & _
"Albarrßn, Socorro 2 sinaloenses y 3 colombianas (1998) [Cela]" & @CRLF & _
"Albarus-Lindo, Carmeta "Aftermath with William Shatner" (2010) {Confessions of the DC Sniper with William Shatner: An Aftermath Special (#1.0)} [Herself] <7>" & @CRLF & _
"Albas, Michelle "Crash Test Mommy" (2004) {Michelle Albas (#1.8)} [Herself - Crash Test Mommy]" & @CRLF & _
"Albas, Montse Omar Martφnez (2006) (TV) [MΘdico] <15>" & @CRLF & _
"Albasetti, Eliana "Buenos dφas a todos" (1991) {(2013-07-08)} [Herself - Guest]" & @CRLF & _
"Albassam, Dalia Gone (2004/II) [Daughter]" & @CRLF & _
"Albassam, Sahar Gone (2004/II) [Mom]" & @CRLF & _
"Albat, Elvan Seytan-i Racim 2: Ifrit (2015)" & @CRLF & _
"Albat, Taiye Aje metta (2008) (V) [Ara ile] <11>" & @CRLF & _
"Albates, Eva "Streit um Drei" (1998) {(#1.284)} [Gisela Bubner]" & @CRLF & _
"Albatis, Marie Herzlutschen (2004) [Swetlana Erdmann]" & @CRLF & _
"Albats, Evgeniya Srok (2014) (uncredited) [Herself]" & @CRLF & _
"Albaugh, Bridget Fly on the Wall (2016) [Gwen]" & @CRLF & _
"Albaugh, Cheryl The Spirits: A Christmas Story (2013) [Extra]" & @CRLF & _
"Albaugh, Sally Desperate Living (1977) [Hag] <24>" & @CRLF & _
"Albaum, Haley Swimming to the Moon (2007) [Background]" & @CRLF & _
"Albaum, Morgan Swimming to the Moon (2007) [Waitress/Dancer]" & @CRLF & _
"Albayati, Anwar Ett ÷ga r÷tt (2007) [Dalanda]" & @CRLF & _
"Albayaty, Leila Berlin Telegram (2012) [Leila]" & @CRLF & _
"Albayaty, Simone Ka∩ros (2015) [Herself]" & @CRLF & _
"Albayrak, Fulya "Melek" (2002) [(2002)]" & @CRLF & _
"Albayrak, Maria "Idol" (2004) {(#2.1)} [Herself]" & @CRLF & _
"Albayrak, Nahsen Sahinler diyari (1958)" & @CRLF & _
"Albayrak, Nebahat "Barend en Van Dorp" (1990) {(2001-11-30)} [Herself - Kamerlid PvdA] <4>" & @CRLF & _
"Albayrak, Nurten "Pauw & Witteman" (2006) {(#6.74)} [Herself - Directeur COA] <6>" & @CRLF & _
"Albayrak, Tugce "CNN Newsroom" (1989) {(2014-11-27)} (archive footage) [Herself - Prⁿgelopfer]" & @CRLF & _
"Albaz, Sana Broken Wings (????) [Herself]" & @CRLF & _
"Albe, Celeste A sangre frφa (las reglas del juego) (2007) [Periodista] <6>" & @CRLF & _
"Albe, Dawn The Least of These (1995) (TV) [Roxanne] <5>" & @CRLF & _
"Albe, Marie Cause toujours, mon lapin (1961)" & @CRLF & _
"Albea, Ami Zombie Apocalypse (2011) (TV) [Zombie] <12>" & @CRLF & _
"Albech, Lillian I lossens time (2013) [Indsat 4]" & @CRLF & _
"Albeck, Alysia The Love Doctor (2015) [Fan]" & @CRLF & _
"Albeck, Bruria Kafe V'Limon (1994) [Michal] <3>" & @CRLF & _
"Albeck, Christine Halby "Klovn" (2005) {Ups (#4.10)} [Christine]" & @CRLF & _
"Albeck, Else Det sande ansigt (1951) <12>" & @CRLF & _
"Albeck, Jeanett "Jarls quizshow" (2012) {(#1.1)} [Herself - Conductor]" & @CRLF & _
"Albeck, Lillan Fasandrµberne (2014) [Posedame pσ hovedbanegσrden] <44>" & @CRLF & _
"Albeck, Lillian "Karrusel" (1998) {8/Ulrich og Lotte (#1.8)} (uncredited) [Dame ved billetlugen]" & @CRLF & _
"Albeck, Lis Flagermusen (1966) <40>" & @CRLF & _
"Albecker, Anne-Claire La chance de ma vie (2011) [RΘceptionnniste h⌠tel] <29>" & @CRLF & _
"Albeda, Martha Mind Walls (2011) [Prakruti]" & @CRLF & _
"Albediwa, Neeven Dark Places (2005) [Donna] <13>" & @CRLF & _
"Albee Sisters, The Turn Off the Moon (1937) [The Albee Sisters] <13>" & @CRLF & _
"Albee, Becca The Punk Singer (2013) [Herself] <6>" & @CRLF & _
"Albee, Gloria Still Dreaming (2014) [Herself - Helena]" & @CRLF & _
"Albee, Lori Naked Ambition: An R Rated Look at an X Rated Industry (2009) (as JC's Girls) [Herself - Christian Outreach Ministry] <8>" & @CRLF & _
"Albee, Lura "Mike Hammer" (1984) {Sex Trap (#1.7)} [Elegant Lady]" & @CRLF & _
"Albee, Mary Crisis in Mid-air (1979) (TV) <45>" & @CRLF & _
"Albee, Nicole (II) The Education Channel (2012) (V) [Herself]" & @CRLF & _
"Albee, Pat Syx (2007) [SYX recruit]" & @CRLF & _
"Albee, Payton What Lies Within Us (2015) [Phoebe]" & @CRLF & _
"Albee, Roxanne (I) Hot Rods to Hell (1967) (uncredited) [Dancer in Floral Outfit]" & @CRLF & _
"Albee, Roxanne (II) Young Guns (2013) [Diana]" & @CRLF & _
"Albeen, Allison Camera Shy (2004) [The Girl] <2>" & @CRLF & _
"Albelda, Mitch Ang huling henya (2013) [Extras at Club Ramp] <150>" & @CRLF & _
"Albelda, Nuria Redes de traici≤n (2014) [Chica exterior]" & @CRLF & _
"Albelo, Anna Margarita Hooters! (2010) [The Investigator]" & @CRLF & _
"Alben, Adriana Aquile (1990) (TV) [Madre di Ferrara]" & @CRLF & _
"Alben, Emily The Feline Feeling (2014) [Hazel Bulleit]" & @CRLF & _
"Albeneau, Cristina L'elefante Rosa (2004)" & @CRLF & _
"Albenga, Cristina La sagrada familia (1988) <15>" & @CRLF & _
"Albeniz, Cecilia La traversΘe du dΘsir (2009) [Herself]" & @CRLF & _
"Alber, Alix Aase AyoΘ Et Syndens Barn (1913) [The Child]" & @CRLF & _
"Alber, Aloma D. Take-Away Spirit (2009)" & @CRLF & _
"Alber, Ariane Glⁿckliche Tage - Am Rande des Abgrunds (1995) [Herzegowina Bihaτ]" & @CRLF & _
"Alber, Franziska Das Haus Anubis - Pfad der 7 Sⁿnden (2012) [Delia] <4>" & @CRLF & _
"Alber, Kim Goblin (1993) (V) [Sherry] <5>" & @CRLF & _
"Alber, Marjorie-Sue "Ripley's Believe It or Not!" (1999) {(#1.20)} [Herself - Roger's Daughter]" & @CRLF & _
"Albera, Blanche IrΦne Leτon de vie (1995)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")