$re = '/([A-z \-]*)(?:,(( [A-z\-\.]*){0,3}(?:\(I*\))?))(.*)\s(\(.*\))\s*(\[.*\])?/';
$str = 'Alba, Tota A la legi≤n le gustan las mujeres... y a las mujeres, les gusta la legi≤n (1976) [Do±a Euduviges] <20>
Alba, Vivi Parφs Tombuct· (1999) [Azafata]
Alba, Yashana Nightmare at Sleepaway Camp on Friday the 13th Part XII (2012) [Tammy Faye] <7>
Albacar, Mar "└nima" (2009) {(#6.3)} [Herself]
Albacete, Isabel Cßndida (2006) [Locutora Anuncio] <33>
Albach, Maeghan Evangerion shin gekij⌠ban: Jo (2007) (voice: English version) [Additional Voices]
Albach, Meaghan "Suzuka" (2005) {Egao (#1.2)} [Additional Voices]
Albach, Stephanie Handcart (2002) [Abigail] <2>
Albach-Retty, Rosa Abenteuer in Wien (1952)
Albachten, Kim As Virgins Fall (2003) [Madge Palsey]
Albadalejo, Ana L\'Agent (2013) (V) [The Party] <6>
Albaicφn, Angustias Violetas imperiales (1952) (uncredited)
Albaicφn, Marφa El secreto del capitßn O\'Hara (1968)
Albain, Julia A Very Potter Musical (2009) (TV) [Crabbe] <14>
Albajari, Nora La traque (2008) (TV) <40>
Albakry, Mouna Born of War (2014) [Wife] <17>
Albala, Shari Syx (2007) [Tour Group Member]
Albaladejo, Ana Cachorro (2004) [Profesora joven] <29>
Albaladejo, Geli 20 centφmetros (2005) [Funcionaria morena - Empleada ETT] <24>
Albaladejo, Lola Manolito Gafotas (1999) [Madre 1] <27>
Albaladejo, Maria "└nima" (2009) {(#7.17)} [Herself]
Albaladejo, Marina "Menudo show" (1995) {(1997-07-26)} [Paloma San Basilio]
Albaladejo, Rocφo "La voz" (2012) {(#1.1)} [Herself - Contestant]
Albaladejo, Tonia "Teatro estudio" (1976) {Las aleluyas del se±or Esteve}
Albalat, Laura Insaciable (2013) [Victima casa somni]
Albalate, Gloria Cinco minutos para medianoche (2010)
Albalate, N·ria Coco rallado (2008) [Mujer]
Albamonte, Cora Empalagßme que me gusta (2006) [Teodora]
Albamonti, Jennifer "The Adventures of Indiana James" (2015) [Bama Breeze Crew Member]
Alban, Alissa Carried Away (1996) [School Board Superintendent] <10>
Alban, Carolyn The Spectre of Edgar Allan Poe (1974) [Virginia Clemm] <17>
Alban, Chantal "Janique aimΘe" (1963) [IrΦne]
Alban, Elizabeth Wildflowers (1999) [Poker Player] <37>
Alban, Franτoise De quoi tu te mΩles Daniela! (1961) <6>
Alban, Ilse "The Man Called X" (1956) {Voice on Tape} <7>
Alban, Jamie The Halfway House (2004) (as Jaimie Alban) [Halfway House Girl] <25>
Alban, Jani Journal d\'un coopΘrant (2010) [Mathilde]
Alban, Karine Dangerous Dreams - Die Macht des Geldes (2001) (V)
Alban, Luz Je suis barbara morgan (2015) [Danseuse]
Alban, Michele A±o u±a (2007) [Grandma Michele] <4>
Alban, Patricia Satanico Pandemonium: La Sexorcista (1975) <14>
Alban, Sarah Eden 11:11 (2010) [Young Girl, Cat]
Alban-Zapata, Joy Das geteilte Glⁿck (2010) (TV) [Mimi Wagner] <7>
Albana, Maya Danish Music Awards 2004 (2004) (TV) [Herself - Presenter (┼rets udenlandske hit)]
Albanchaabouchi, Kahina Bloody Mary (2011/I) [Air hostess]
Albane Rigadin et la poudre d\'amour (1912)
Albane, Blanche L\'homme au grand manteau (1911) <3>
Albanel, Christine L\'aventure du Rond-Point: Audace joyeuse et rire de rΘsistance (2010) (TV) [Herself]
Albanense, Nadia "Como pan caliente" (1996) [Pelusa] <24>
Albanes, Carolina Agent: Undercover (2008) {{SUSPENDED}} [Luna]
Albanese, Anna "Starcade" (1982) {(#1.17)} [Herself - Contestant] <4>
Albanese, Ashleigh Crown Oaks Day (2011) (TV) [Herself]
Albanese, Chrissy Fat Kid Luv (2009) [Partygoer] <13>
Albanese, Francesca (R)evolution (2014) (V) [The Girl]
Albanese, Giada Banzai (1997) [Duty Free Cashier]
Albanese, Judy "Cavuto on Business" (2000) {(2014-07-18)} [Herself (segment "Let Me Be Brief")]
Albanese, Kelly Buffy the Vampire Slayer: Season 8 Motion Comic (2011) (V) [Buffy]
Albanese, Lauren "Confessions of a Bartender" (2015) [(2014)]
Albanese, Licia Little Shop of Erotica (2001) [Restaurant Patron] <21>
Albanese, Lindsay Operation Shock and Awe... some (2008) [Jenni]
Albanese, Marta Operaci≤n masacre (1973)
Albanese, Michela Il burbero (1986)
Albanese, Michele "StartUpers" (2012) [Herself] <3>
Albanese, Stephanie Eternal Black (2014) [Adult Sam/Narrator]
Albanese, Tina "JAG" (1995) {Code Blue (#2.13)} (uncredited) [Cashier]
Albanese, Zira Alzira\'s Story (2000) [Herself] <6>
Albanese-Smith, Amanda "The Stools" (2015) {Chapter Five: More 1957 (#1.5)} [Betheny Bedstuy-Jones]
Albanesi, Meggie Darby and Joan (1919) [Elin Garry] <5>
Albanez, Caroline Manny\'s Obituary (2011) [Maggie] <5>
Albanez, Diana "Teachers Talking About..." (2014) [Herself - Guest]
Albaneze, Ljiljana "Svaki dan dobar dan" (2013) {Ucenje - (Ni) je mucenje (#1.3)} [Herself]
Albanezzi, Nilza O Artesπo de Mulheres (1978) <10>
Albani, Andrea (I) Agφtese antes de usarla (1983) (as Laly Espinet) [Elisa] <11>
Albani, Angela Patima (1975) <20>
Albani, Elsa Come, quando, perchΘ (1969) [Marco\'s mother] <4>
Albani, Laura Auto-Ceva - Eine Begegnung und fⁿnf Reisen nach Bukarest (2010) [Herself] <2>
Albani, Marcella Amore in fuga (1921)
Albani, Maria Teresa Amore e ginnastica (1973) <11>
Albani, Olga The Lady in Black (1935) (as Countess Olga Albani) [Countess Olga Albani] <1>
Albani, Zoe Din prea multa dragoste (1986)
Albani-Cook, Maria "Snapped: Killer Couples" (2011) {Jennifer Henderson & Skylar Deleon (#1.2)} [Notary]
Albania, Annie In da Red Corner (2006) [Real Boxer] <66>
Albaniah, Nor Al-Hijab (2011) [Datin] <4>
Albano, Bea Edward Scissorhands (1990) [Rich Widow/TV] <36>
Albano, Donna A Modern Day Western: The Sanchez Saga (1997) [Detective Leslie Henderson]
Albano, Editha Thelma (2011) [Empanada Vendor, Batac Market] <28>
Albano, Flora R. My Name Is Bruce (2007) [Old Lady] <36>
Albano, Gia Santa Claws (2014) [Little Girl] <22>
Albano, Jennie (I) The Crib (2005) [Alluring Nurse #2]
Albano, Jennie (II) "Take the Money & Run" (2011) {The South Beach Sisters (#1.3)} [Herself - Contestant] <6>
Albano, Jennifer 200 Cigarettes (1999) [Cheryl] <3>
Albano, Jessica "Prince$$" (2010) {Laura H. (#2.27)} [Herself - Stylist]
Albano, Jill The Grounded (2013/I) [Missy-Ann] <1>
Albano, Kelly 30 Seconds from Oblivion (2010) (V) (as Kelly Marchand) [Lexi Warthers]
Albano, Mariela Placer sangriento (1967)
Albano, Martina La solitudine dei numeri primi (2010) [Young Alice] <3>
Albano, Mary La bestia desnuda (1971)
Albano, Meghan Pay It Forward (2000) (uncredited) [Neighbor]
Albano, Michele "Throwdown with Bobby Flay" (2006) {Pumpkin Pie (#7.5)} [Herself - Owner, Michele\'s Pies]
Albano, Patrizia Attenti a quei due napoletani (1980)
Albano, Pina Faida (1988)
Albano, Rebecca "Take the Money & Run" (2011) {The South Beach Sisters (#1.3)} (as Rebecca) [Herself - Contestant] <5>
Albano, Serena Ultime notizie (1995)
Albano, Stefania Il cappellino (2009)
Albano, Tulsi 10 Hours State of Emergency (2013) [News Reporter]
Albano, Victoria Jack Rio (2008) [Waitress]
Albanova, Olga Nelegal (2006) [Svetlana] <3>
Albany, Alison Busted (2015) [Office Worker] <19>
Albany, Fernande Flagrant dΘlit (1931) [Hortense] <7>
Albany, Jade (I) "Camp" (2013) {Pilot (#1.1)} [Alex] <18>
Albao, Baby Scaregivers (2008) [Jewelry Shop Customer] <57>
Albao, Theresita Scaregivers (2008) [Jewelry Shop Customer] <58>
Albar, Shelley The Bridge (2006/I) [Herself - David\'s Friend, Oakland, CA] <25>
Albarado, Clara La voz del agua (2015) [Mezzosoprano]
Albardonedo, Deborah Bellas durmientes (2001) [Mujer de cuatro piernas] <29>
Albareda, Teresa Pell Fina (2015)
Albareil, Josette PygomΦle (2011) [La Servante] <5>
Albarella, Jackie Traveling Salesmen (2008) [Mystic Judy Giordano] <6>
Albarella, Karen Fixations (2010) [Group Member]
Albarelli, Kathryn "Law & Order: Criminal Intent" (2001) {Unchained (#5.4)} [Judy Cordova] <26>
Albares, Ana Isabel (I) XIV Premios Anuales Iris de la Academia de TV (2012) (TV) [Herself]
Albares, Ana Isabel (II) XIV Premios Anuales Iris de la Academia de TV (2012) (TV) [Herself - Presenter]
Albaret, Sylvia Les chants de Mandrin (2011) [Mandrinette] <10>
Albarez, Angela Franchise (2012)
Albarez, Maria Dolores Ellos Volvieron (2015) [Classmate] <21>
Albaroto, Carla Thelma (2011) [University of Makati] <491>
Albarracin, Mayra Insane (????) [Belen]
Albarracin, Taca Nocturnal Jake (2009) [Sophia] <2>
Albarracφn, Adriana "La casa de las dos palmas" (1991) [Hortencia Herreros (1991)]
Albarracφn, Magnolia La pasi≤n de Gabriel (2008) [Do±a Carmen]
Albarracφn, Marcela Invierno ausente (2005) [Elvira]
Albarracφn, Nadia "Guapas" (2014) {Falsa alarma (#1.168)} [Bombero]
Albarreal, Cecilia Dramagogφa barata (2005)
Albarret, CΘleste Portrait-souvenir: Marcel Proust (1962) (TV) [Herself]
Albarrosa, Rosanny Stand Clear of the Closing Doors (2013) [Nail clipper]
Albarrßn, Karla "Amor gitano" (1999) <32>
Albarrßn, Socorro 2 sinaloenses y 3 colombianas (1998) [Cela]
Albarus-Lindo, Carmeta "Aftermath with William Shatner" (2010) {Confessions of the DC Sniper with William Shatner: An Aftermath Special (#1.0)} [Herself] <7>
Albas, Michelle "Crash Test Mommy" (2004) {Michelle Albas (#1.8)} [Herself - Crash Test Mommy]
Albas, Montse Omar Martφnez (2006) (TV) [MΘdico] <15>
Albasetti, Eliana "Buenos dφas a todos" (1991) {(2013-07-08)} [Herself - Guest]
Albassam, Dalia Gone (2004/II) [Daughter]
Albassam, Sahar Gone (2004/II) [Mom]
Albat, Elvan Seytan-i Racim 2: Ifrit (2015)
Albat, Taiye Aje metta (2008) (V) [Ara ile] <11>
Albates, Eva "Streit um Drei" (1998) {(#1.284)} [Gisela Bubner]
Albatis, Marie Herzlutschen (2004) [Swetlana Erdmann]
Albats, Evgeniya Srok (2014) (uncredited) [Herself]
Albaugh, Bridget Fly on the Wall (2016) [Gwen]
Albaugh, Cheryl The Spirits: A Christmas Story (2013) [Extra]
Albaugh, Sally Desperate Living (1977) [Hag] <24>
Albaum, Haley Swimming to the Moon (2007) [Background]
Albaum, Morgan Swimming to the Moon (2007) [Waitress/Dancer]
Albayati, Anwar Ett ÷ga r÷tt (2007) [Dalanda]
Albayaty, Leila Berlin Telegram (2012) [Leila]
Albayaty, Simone Ka∩ros (2015) [Herself]
Albayrak, Fulya "Melek" (2002) [(2002)]
Albayrak, Maria "Idol" (2004) {(#2.1)} [Herself]
Albayrak, Nahsen Sahinler diyari (1958)
Albayrak, Nebahat "Barend en Van Dorp" (1990) {(2001-11-30)} [Herself - Kamerlid PvdA] <4>
Albayrak, Nurten "Pauw & Witteman" (2006) {(#6.74)} [Herself - Directeur COA] <6>
Albayrak, Tugce "CNN Newsroom" (1989) {(2014-11-27)} (archive footage) [Herself - Prⁿgelopfer]
Albaz, Sana Broken Wings (????) [Herself]
Albe, Celeste A sangre frφa (las reglas del juego) (2007) [Periodista] <6>
Albe, Dawn The Least of These (1995) (TV) [Roxanne] <5>
Albe, Marie Cause toujours, mon lapin (1961)
Albea, Ami Zombie Apocalypse (2011) (TV) [Zombie] <12>
Albech, Lillian I lossens time (2013) [Indsat 4]
Albeck, Alysia The Love Doctor (2015) [Fan]
Albeck, Bruria Kafe V\'Limon (1994) [Michal] <3>
Albeck, Christine Halby "Klovn" (2005) {Ups (#4.10)} [Christine]
Albeck, Else Det sande ansigt (1951) <12>
Albeck, Jeanett "Jarls quizshow" (2012) {(#1.1)} [Herself - Conductor]
Albeck, Lillan Fasandrµberne (2014) [Posedame pσ hovedbanegσrden] <44>
Albeck, Lillian "Karrusel" (1998) {8/Ulrich og Lotte (#1.8)} (uncredited) [Dame ved billetlugen]
Albeck, Lis Flagermusen (1966) <40>
Albecker, Anne-Claire La chance de ma vie (2011) [RΘceptionnniste h⌠tel] <29>
Albeda, Martha Mind Walls (2011) [Prakruti]
Albediwa, Neeven Dark Places (2005) [Donna] <13>
Albee Sisters, The Turn Off the Moon (1937) [The Albee Sisters] <13>
Albee, Becca The Punk Singer (2013) [Herself] <6>
Albee, Gloria Still Dreaming (2014) [Herself - Helena]
Albee, Lori Naked Ambition: An R Rated Look at an X Rated Industry (2009) (as JC\'s Girls) [Herself - Christian Outreach Ministry] <8>
Albee, Lura "Mike Hammer" (1984) {Sex Trap (#1.7)} [Elegant Lady]
Albee, Mary Crisis in Mid-air (1979) (TV) <45>
Albee, Nicole (II) The Education Channel (2012) (V) [Herself]
Albee, Pat Syx (2007) [SYX recruit]
Albee, Payton What Lies Within Us (2015) [Phoebe]
Albee, Roxanne (I) Hot Rods to Hell (1967) (uncredited) [Dancer in Floral Outfit]
Albee, Roxanne (II) Young Guns (2013) [Diana]
Albeen, Allison Camera Shy (2004) [The Girl] <2>
Albelda, Mitch Ang huling henya (2013) [Extras at Club Ramp] <150>
Albelda, Nuria Redes de traici≤n (2014) [Chica exterior]
Albelo, Anna Margarita Hooters! (2010) [The Investigator]
Alben, Adriana Aquile (1990) (TV) [Madre di Ferrara]
Alben, Emily The Feline Feeling (2014) [Hazel Bulleit]
Albeneau, Cristina L\'elefante Rosa (2004)
Albenga, Cristina La sagrada familia (1988) <15>
Albeniz, Cecilia La traversΘe du dΘsir (2009) [Herself]
Alber, Alix Aase AyoΘ Et Syndens Barn (1913) [The Child]
Alber, Aloma D. Take-Away Spirit (2009)
Alber, Ariane Glⁿckliche Tage - Am Rande des Abgrunds (1995) [Herzegowina Bihaτ]
Alber, Franziska Das Haus Anubis - Pfad der 7 Sⁿnden (2012) [Delia] <4>
Alber, Kim Goblin (1993) (V) [Sherry] <5>
Alber, Marjorie-Sue "Ripley\'s Believe It or Not!" (1999) {(#1.20)} [Herself - Roger\'s Daughter]
Albera, Blanche IrΦne Leτon de vie (1995)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);