$re = '/([A-Z])\w+\s([A-Z])\w*\s*([A-Z])*(?=,*)/';
$str = 'Bill Joney Jones, III';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);