package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m):?([^@\n]*)@`)
var str = `sip:+8610086@dmcw.com
+8610086@dmcw.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}