$re = '/:?([^@\n]*)@/m';
$str = 'sip:+8610086@dmcw.com
+8610086@dmcw.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);