package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\/(.*)`)
var str = ` http://example.com/name/first_name/last_name/John%2C+Smith`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}