$re = '/.*\/(.*)/';
$str = ' http://example.com/name/first_name/last_name/John%2C+Smith';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);