$re = '/[2-9][0-9][0-9]\-[2-9][0-9][0-9]-[0-9][0-9][0-9][0-9]/';
$str = '999-999-9999';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);