const regex = new RegExp('^[aeiou]', 'gm')
const str = `faulty and/ERT something worse/VBN and/ERT else/VHGB and/ERT as/VVFIN propositions one and/ERT two/CDF and/ERT three/ABC`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}