import re
regex = re.compile(r"^[aeiou]", flags=re.MULTILINE)
test_str = "faulty and/ERT something worse/VBN and/ERT else/VHGB and/ERT as/VVFIN propositions one and/ERT two/CDF and/ERT three/ABC"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")