package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)[0-9][0-9 ]{7,10}-[A-Z]`)
var str = `asd 45 888 711-P `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}