$re = '/[0-9][0-9 ]{7,10}-[A-Z]/im';
$str = 'asd 45 888 711-P ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);