re = /,(?=(?:(?:[^"]*\"){2})*[^"]*$)/
str = '1,"2,2,2",three,\'four, 4\',,"6\\tsix"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end