$re = '/\[[^[\]]+\](?=[^[\]]*(\[[^[\]]+\])*[^[\]]*\])/m';
$str = '[[hello] this should [match]] [not ok]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);