re = /\[[^[\]]+\](?=[^[\]]*(\[[^[\]]+\])*[^[\]]*\])/m
str = '[[hello] this should [match]] [not ok]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end