package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-ZĄĆĘŁŃÓŚŹŻ][a-ząćęłńóśźż]+,? [A-ZĄĆĘŁŃÓŚŹŻ][a-ząćęłńóśźż]+)`)
var str = `Imię i nazwisko: Hubar, Patryk. Data urodzenia: 7 czerwca 1993. Numer telefonu: 123-456-789, Imię i nazwisko: Mickiewicz, Adam. Data urodzenia: 22 stycznia
1877. Numer telefonu: 789 456 123
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}