import re
regex = re.compile(r"([A-ZĄĆĘŁŃÓŚŹŻ][a-ząćęłńóśźż]+,? [A-ZĄĆĘŁŃÓŚŹŻ][a-ząćęłńóśźż]+)", flags=re.MULTILINE)
test_str = ("Imię i nazwisko: Hubar, Patryk. Data urodzenia: 7 czerwca 1993. Numer telefonu: 123-456-789, Imię i nazwisko: Mickiewicz, Adam. Data urodzenia: 22 stycznia\n"
"1877. Numer telefonu: 789 456 123\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")