#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[\[https?:\/\/vimeo\.com\/[^\]]*?(\d+)\]\]"
Local $sString = "[[https://vimeo.com/channels/mercedesbenz/166551756]]" & @CRLF & _
"[[https://vimeo.com/153002910]]" & @CRLF & _
"[[https://vimeo.com/jp/channels/staffpicks/259634725]]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")