package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[\[https?:\/\/vimeo\.com\/[^\]]*?(\d+)\]\]`)
var str = `[[https://vimeo.com/channels/mercedesbenz/166551756]]
[[https://vimeo.com/153002910]]
[[https://vimeo.com/jp/channels/staffpicks/259634725]]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}