using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*(?=:)";
string input = @"Interface ClientA(CLIENTA): Bits received
Interface ClientB(CLIENTB): Bits received
Interface ClientC(CLIENTC): Bits received
Interface ClientD(CLIENTD): Bits received";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}