$re = '/^.*(?=:)/m';
$str = 'Interface ClientA(CLIENTA): Bits received
Interface ClientB(CLIENTB): Bits received
Interface ClientC(CLIENTC): Bits received
Interface ClientD(CLIENTD): Bits received';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);