package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^a-zA-Z\n\r()]+)`)
var str = `this is a string
This is a string
This is a (string)
This is a string
This is a string+`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}