$re = '/([^a-zA-Z\n\r()]+)/m';
$str = 'this is a string
This is a string
This is a (string)
This is a string
This is a string+';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);