$re = '/"(\d+)"(?=[^{]*})/';
$str = 'i:0;s:2:"34";i:1;s:2:"35";a:29:{i:0;s:2:"34";i:1;s:2:"35";i:2;s:2:"37";i:3;s:2:"36";i:4;s:2:"38";i:5;s:2:"41";i:6;s:2:"33";i:7;s:2:"17";i:8;s:2:"20";i:9;s:2:"18";i:10;s:2:"19";i:11;s:2:"22";i:12;s:2:"23";i:13;s:2:"16";i:14;s:2:"21";i:15;s:2:"43";i:16;s:2:"70";i:17;s:2:"91";i:18;s:2:"50";i:19;s:2:"48";i:20;s:2:"49";i:21;s:2:"53";i:22;s:2:"47";i:23;s:2:"46";i:24;s:2:"44";i:25;s:3:"106";i:26;s:3:"121";i:27;s:2:"95";i:28;s:2:"86";};i:0;s:2:"34";i:1;s:2:"35";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);