package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^\/contact-us\/global-contact-list\.aspx)|(^\/contact-us\/$)`)
var str = `/contact-us/global-contact-list.aspx
/contact-us/
/contact-us/contactlist/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}