re = /(^\/contact-us\/global-contact-list\.aspx)|(^\/contact-us\/$)/m
str = '/contact-us/global-contact-list.aspx
/contact-us/
/contact-us/contactlist/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end