using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\/contact-us\/global-contact-list\.aspx)|(^\/contact-us\/(?!contactlist\/))";
string input = @"/contact-us/global-contact-list.aspx
/contact-us/
/contact-us/contactlist/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}