$re = '/(^\/contact-us\/global-contact-list\.aspx)|(^\/contact-us\/(?!contactlist\/))/m';
$str = '/contact-us/global-contact-list.aspx
/contact-us/
/contact-us/contactlist/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);