package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[A-Za-z]{2}[0-9]{2}[A-Za-z]{1,2}[0-9]{1,4}`)
var str = `MH21A4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}