const regex = /(?:[^;]*;?){1,5}/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[^;]*;?){1,5}', 'm')
const str = `sdfsdf;sdfsd;sdf;sdfd;sdf;sdf;sdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}