$re = '/(?:[^;]*;?){1,5}/m';
$str = 'sdfsdf;sdfsd;sdf;sdfd;sdf;sdf;sdf';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);