# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\S)\s{2,}(?=\S)/\1 /gm;t' <<< " Hi, this is a good time to start working together.
Hi, this is a good time to start working together.
Hi, this is a good time to start working together. "