re = /(\S)\s{2,}(?=\S)/m
str = ' Hi, this is a good time to start working together.
Hi, this is a good time to start working together.
Hi, this is a good time to start working together. '
subst = '\\1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result