import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)(?:.+(?:\\n.)?)+";
final String string = "Lorem ipsum dolor sit amet, consetetur sadipscing elitr,\n"
+ "sed diam nonumy eirmod tempor invidunt ut labore et dolore\n"
+ "magna aliquyam erat, sed diam voluptua. At vero eos et\n"
+ "accusam et justo duo dolores et ea rebum.\n\n"
+ "Stet clita kasd gubergren, no sea takimata sanctus est Lorem\n"
+ "ipsum dolor sit amet.\n\n\n"
+ "Ipsum dolor sit amet, consetetur sadipscing elitr, sed diam\n"
+ "nonumy eirmod tempor invidunt ut labore et dolore magna\n"
+ "aliquyam erat, sed diam voluptua. At vero eos et accusam et\n"
+ "justo duo dolores et ea rebum. Stet clita kasd gubergren, no\n"
+ "sea takimata sanctus est Lorem ipsum dolor sit amet.\n\n\n\n"
+ "ART. WEFWEFEW\n"
+ " 1 SDVSDRG:\n"
+ " a. wevvdfvdfd\n"
+ " b. sdfsdfsdfsdfsdfsdghtrhrth";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}