#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d+:\d+(?:(?!\d+:\d)[\s\S])*"
Local $sString = "1:1 wefeff qwefejä qwefjk" & @CRLF & _
"dfjdf 10:2 jdskjdksdjö" & @CRLF & _
"12:1 qwe qwe: qwertyå"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")