$re = '/(?<=\[;;)?\w+(?=\])/m';
$str = 'This is a [;;Text] and I want to match [center]everything without ;;[/center]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);