re = /(?<=\[;;)?\w+(?=\])/m
str = 'This is a [;;Text] and I want to match [center]everything without ;;[/center]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end