using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(-?\d*\.?\d+E[+-]?\d+)""";
string substitution = @"$1";
string input = @"""23452345235E9"", ""0342953475409E9"", 324598732450843, ""fooo"", ""2034598324509E9"", 12342340985, ""baaar"", 234098549034E9, 453409340923";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}