const regex = /"(-?\d*\.?\d+E[+-]?\d+)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"(-?\\d*\\.?\\d+E[+-]?\\d+)"', 'g')
const str = `"23452345235E9", "0342953475409E9", 324598732450843, "fooo", "2034598324509E9", 12342340985, "baaar", 234098549034E9, 453409340923`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);